Python 2025.10. Forgalomszdmldlas

BLZS©

Egy varos kozlekedéstervezesi ccllal kerckparosforgalom-szamlalot telepit az egyik
foutjara. A probaiizem reggel 6-tol 10-ig tart, amelynek soran 15 percenként rogzitik
a megelozd 15 percben athalado kerékparosok szamat. A rendszer még bizonytalan, ha
technikai probléma — példaul aramsziinet — torténik a mérés soran barmikor, akkor a rogzitett
¢rtek abban az idointervallumban -1 lesz, kiilonben az athaladok szama nemnegativ egész szam.

A rogzitett mérési ertekek szama 16, és értekiik peldaul a kdvetkezo:
36, 48, 39, -1, 30, 43, -1, 76, 67, 82, 73, 75, 64, 73, 69, 63
A merés kezdoadatai: 6:15-kor 36, 6:30-kor 48 kerékparos, ¢s igy tovabb. 7:00-kor és

7:45-kor -1  keriilt rogzitésre, mert az elozd negyedoraban meérohiba tortént
a szamlalorendszerben. Az utolso adatot, 63 kerckparost 10:00-kor jegyeztck fel.

Keészitsen programot, amely megvalaszolja a mérési eredményekre vonatkozo kérdéseket!

A program forraskodjat mentse szamlalas néven! A program megirasakor a meéresi
adatok szamat és helyességet nem kell ellendriznie. A programnak akkor is helyesen kell
miikddnie, ha a programban tarolt adatokat mas, megfelelo adatokra csercljiik.

A keépernyore irast igénylo reszfeladatok esetén az ckezetmentes kiiras is elfogadott.
A mintdhoz tartalmaban hasonloan irja ki a képernyore a feladat sorszamat
(peldaul: 2. feladat), valamint utaljon a kiirt tartalomra 1s!
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A feladat leirdsa

BLZS©

A megadott 16 szamot tarolja el a program forrasaban egy megfeleld adatszerkezetben!
A 16 szam rendelkezésre all a meres. txt allomanyban, amelybol a program kodjaba
atmasolhatok.

A forgalomszamlalo adatai alapjan hatarozza meg az athaladt 6sszes kerckparos szamat, ¢s
irassa ki a minta szerint! Ugyeljen arra, hogy a szamitas soran a mérohibas adatok ne
befolyasoljak az Gsszeget!

frassa ki a képernyore a mintanak megfeleloen, hogy oranként hany kerékparos haladt at
a szamlalon!

Hatarozza meg a legnagyobb mérési ertéket ¢s rogzitésének idopontjat! Az eredmeényt irassa
ki a mintanak megfelelo formatumban! Tobb maximalis érték esetén az elsot jelenitse meg!
A feladat szempontjabol most egyforman helyesnek tekintjiik a 07:00, 7:00, 7:0
irasmodot is.

Minta a sziveges kimenet kialakitiasahoz:

2.

feladat

Osszesen 838 kerékparost szamoltak.

3.

feladat

Orankénti mérések:

6
7

8
9

4,

6ratdél 123 kerékpéaros
6ratdél 149 kerékparos
6ratdél 297 kerékparos
6ratdl 269 kerékpéaros

feladat

Az athaladdék maximalis szama: 82; a rogzités iddépontja: 8:30.
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Az elkészitett program

# 1. FELADAT: Adatok eltarolasa
meresek = [ 36, 48, 39, -1, 30, 43, -1, 76, 67, 82, 73, 75, 64, 73, 69, 63 |

feladathoz kezddknek:
. k 16 idopontunk van, a legkdnnyebb, ha ezeket is egyszerien felsoroljuk!
idopontok = [ "6:15", "6:30", "6:45", "7:0@", "7:15", "7:30", "7:45", "8:00",
"8:15", "8:30", "8:45", "9:00", "9:15", "9:30", "9:45", "10:00" ]

# 2. FELADAT: Osszes kerékparos
print(“2. feladat™)
osszesen = @
for adat in meresek: aktualis_index = @
if adat I= -1:
osszesen = osszesen + adat for ora in [6, 7, 8, 9]:
ora_osszege = ©
for lepes in range(4):
adat = meresek[aktualis index]
if adat l= -1:
# 3. FELADAT: Orankénti mérések ora osszege = ora osszege + adat
print("3. feladat™) aktualis index = aktualis index + 1
print("Orankénti mérések:™)

print(f"0Osszesen {osszesen} kerékparost szamoltak.™)

print(f"{ora} oratol {ora osszege} keréekparos™)

# 4. FELADAT: Legnagyobb mérési érték
print("4. feladat™)
max_ertek = -1

max_index = @

for i in range(len(meresek)):
if meresek[i] > max ertek:
max_ertek = meresek[1]
max_index = 1

print(f"Az athaladok maximalis szama: {max ertek}; a rogzités idopontja: {idopontok|[max index]}.")




1. Adatok eltdroldsa BLZS©
A feladat kéri, hogy a 16 megadott szdmot tdroljuk el a forrdskédban

egy adatszerkezetben.

meresek = [...] Ezt a szerkezetet listdnak hivjuk. Képzeld el dgy, mint egy

nagy iratrendezét, amiben rekeszek vannak, és mindegyik rekeszbe bedobunk

egy szamot, amit a meres.txt-bdl kaptunk.

idopontok = [...] Ahelyett, hogy a 4. feladatban bonyolult matematikaval
szdmolndnk ki az id6t a sorszdmokbdl, készitiink egy masik listat az
idopontoknak. A mérések 6:15-kor kezdddtek , és 10:00-ig tartottak. Ha
tudjuk hanyadik mérés volt a legnagyobb, csak megnézziik ugyanezt a
sorszdamot az idépontok listdjaban.

# 1. FELADAT: Adatok eltarolasa
meresek = [ 36, 48, 39, -1, 3@, 43, -1, 76, 67, 82, 73, 75, 64, 73, 69, 63 ]

# Segédlet a 4. feladathoz kezdoknek:
# Mivel csak 16 iddpontunk van, a legkonnyebb, ha ezeket is egyszeriien felsoroljuk!
idopontok = [ "6:15", "6:3@", "6:45", "7:@0", "7:15", "7:30", "7:45", "8:00",

BLZS@ "8:15", "8:30", "8:45", "9:00", "9:15", "9:30", "9:45", "18:00" |
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2. Osszes athalado kerékpdros BLZS

I'tt ossze kell adnunk a szamokat, de figyelniink kell arra,
hogy a hibdt jelz6 -1 -eket kihagyjuk.

print(“2. feladat") Kiirja a képernydre a szoveget.

osszesen = O Létrehozunk egy képzeletbeli "dobozt" (valtozdt),
amibe gy(jtjik a kerékpdarosokat. Kezdetben ez nulla.

for adat in meresek: Ez egy ciklus.
Menj végig a meresek listdn, fogd meg sorban az 6sszes elemet,
és hivjuk most az éppen aktudlisat adat-nak.

# 2. FELADAT: Osszes kerékparos
print("2. feladat™)

osszesen = @

for adat in meresek:

if adat 1= -1:
ossZesen = osszesen + adat

BLZS@ print(f"Osszesen {osszesen} kerékparost szamoltak.™)
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2. Osszes athalado kerékpdros BLZS

if adat I= -1: Ez egy feltétel. A |= jelenti azt, hogy "nem egyenld".
Tehat: "HA az adat nem egyenlé -1-gyel....,

osszesen = osszesen + adat "..akkor az eddigi 6sszeghez add hozza
az aktudlis adatot." (Ha az adat -1 volt, a gép ezt a sort dtugorja).

print(f"Osszesen {osszesen} ...") Az f a szoveg elétt azt jelenti, hogy
"formazott" szoveg. Lehetévé teszi, hogy a szévegen beliil kapcsos zdréjelek {}
kozé betehessiik egy doboz tartalmat.

# 2. FELADAT: Osszes kerékparos
print("2. feladat™)
osszesen = @
for adat in meresek:
if adat = -1:
osszesen = osszesen + adat

print(f"Osszesen {osszesen} kerékparost szamoltak.™)

BLZS©



< ©
3. Ordnkénti mérések BLZS
Mivel a mérések 15 percenként torténtek, egy oraban pontosan 4 mérés van.

aktualis_index = O Ez lesz a mi "mutatéujjunk", amivel kovet jik,
hol tartunk az iratrendezdében (a meresek listaban).

for ora in [6, 7, 8, 9]: Négy drank van, ezeken megyiink végig.

ora_osszege = O Minden dj ora kezdetén lenullazzuk a szamldlét.

# 3. FELADAT: Orankénti mérések
print("3. feladat™)
print("6rankénti mérések:")

aktualis index = ©

for ora in [6, 7, 8, 9]:
ora_osszege = @
for lepes in range(4):
adat = meresek|[aktualis index]
if adat I= -1:
ora_osszege = ora_osszege + adat
aktualis index = aktualis index + 1

BLZ S print(f"{ora} oratol {ora osszege} kerekparos")
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3. Orénkénti mérések BLZS

for lepes in range(4): Minden dradn beliil pontosan 4-szer kell |épniink
(4 negyedodra).

adat = meresek[aktualis_index] A szogletes zdrdjel [] segitségével vessziik ki
a listabadl azt az elemet, amire a mutatdéujjunk (aktualis_index) épp mutat.

aktualis_index = aktualis_index + 1 Miutan feldolgoztunk egy elemet,
a mutatdujjunkat eggyel odébb toljuk.

# 3. FELADAT: Orankénti mérések
print("3. feladat™)
print("Orankénti mérések:™)

aktualis index = @

for ora in [6, 7, 8, 9]:
ora_osszege = @
for lepes in range(4):
adat = meresek[aktualis index]
if adat I= -1:
ora_osszege = ora_osszege + adat
aktualis index = aktualis index + 1

BLZS© print(f"{ora} oratol {ora osszege} kerekparos")
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4. Maximum keresés BLZS
Meg kell keresniink a legmagasabb értéket és annak idejét.

max_ertek = -1 és max_index = O A maximumkeresés triikkje az,
hogy kineveziink egy nevetségesen alacsony szamot
a "jelenlegi legnagyobb" (bajnok) értéknek.

for i in range(len(meresek)): Végigmegyiink a mérések sorszdmain.
A Python a sorszdmozdst O-16l kezdi (0, 1, 2... 15).

# 4. FELADAT: Legnagyobb mérési ertek
print("4. feladat"™)

max_ertek = -1

max_index = @

for i in range(len(meresek)):

if meresek[i] > max ertek:

max_ertek = meresek[1]
max_index = 1

BLZS@ print(f“Az athaladok maximalis szama: {max ertek}; a rogzites idopontja: {idopontok[max index]}."



4. Maximum keresés

BLZS©

if meresek[i] > max_ertek: "HA a most vizsgdlt érték nagyobb,
mint az eddigi bajnok...,,

max_ertek = meresek[i] és max_index = i "...akkor legyen 6 az 4j bajnok,
és jegyezziik meg a sorszdmdt is (max_index)!".

print(f"... {idopontok[max_index]}.") A végén az idépontok listdjabdl
egyszer(en elévessziik a nyertes sorszdmdhoz tartozé idét .

BLZS©

# 4. FELADAT: Legnagyobb mérési ertek
print("4. feladat"™)

max_ertek = -1

max_index = @

for i in range(len(meresek)):
if meresek[i] > max ertek:
max_ertek = meresek[1]
max_index = 1

print(f“Az athaladok maximalis szama: {max ertek};

a rogzites idopontja: {idopontok[max index]}."




Tipikus hibdk! BLZS®

A "behizasok" (Indentacio) hianya vagy keverése: A Pythonban nagyon fontosak a
sorok elején |évé sz6kozok (dltalaban 4 szokoz vagy egy Tab). Ezek jelzik, hogy melyik
utasitds tartozik bele a for ciklusba vagy az if feltételbe. Ha ezek nincsenek jo
helyen, a program hibdat fog dobni, vagy rosszul szamol.

A nulla-alapi sorszamozas elfelejtése: Ne feledd, a szdmitdgép nullatol kezd
szdmolni! A meresek lista legelsé eleme a meresek[0], a mdsodik a meresek[1]. Ha ezt
elrontod, minden adat elcsidszik egy hellyel.

Vdltozonevek elgépelése: A gép nem érti a magyar nyelvet, csak az dltalad kitaldlt
neveket. Ha valahol osszesen névvel hoztadl lIétre egy vdltozot, de késébb oszesen-
ként hivatkozol rd, a gép 6sszeomlik, mert szerinte olyan "doboz" nem Iétezik.

Kis- és nagybetiik felcserélése: A Python (és a legtébb programnyelv) “case-
sensitive". Ez azt jelenti, hogy a max_ertek és a Max_ertek szamadra két teljesen
kiilonbozd dolog. Maradj a kisbet(ik haszndlatdndl, dgy a legbiztonsagosabb!

BLZS©
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VS Code w 8LZS

PyCharm Python 3.13 VS Code
Community...

File -> New Project -> kihivas-> Create New File-> Mentés helye -> Create File

: S : New File...
New File... Cirl+ Alt+Windows+N '

Kihiva

MNew Window

n Window with P Create New File (Kihivas) Built-In

en FIlE‘ ¥ Create File X
i F"_'ll'_i-':"r' ™ « _2026-iskola > _digi-erettsegi-kozep > 05_python > 2505 v O Keresés: 25.05 P
i Wo r-|.::-_- Rendezés = Uj mappa = - o

o plUnkosd2 Név Modositas datuma Tipus Méret
fotok fotok 5. 25. 14:39 Fajlmappa
25.05 £ 2505-prog-kihivas.pdf 1. 05. 22:58 Chrome PDF Docu... 178 KB
"] 25.05-prog-kihivas-m.pptx )5. 19. 7:04 Microsoft PowerPo... 1161 KB
% iCloud Drive @| kihivas.py 5. 25, 14:40 Python forrasfa) 1KB
B Ezagép

- Helyi lemez (C:)|

p= pCloud Drive (P:

Fajinév: -

Fajl tipusa: All Files (*%) A4

BI Z S A~ Mappéak elrejtése Create File Megse




VS Code

PyCharm Python 3.13

VS Code

Community...

BLZS©

File -> New Project -> befozes-> Create New File-> Mentés helye -> Create File

File -> Save As... -> Fdjl tipusa:

New Text File
New File...
New Window

New Window with Profile

Open Fi
Open Folder...
Open Workspace from File...

Open Recent

Add Folder to Workspace...

Save Work

Duplicate Workspace

Sa

Save As... Ctrl+Shift+S
Save All

Share

Auto Save

Preferences

Revert File
Close Editor

ose Window

Exit

Ml JavaScript JSX (*jsx)

! B 1o 2 jinja2)

jutalom = 19N (*json;* bowerrc;* jscsrc;*.webmanifest;* js.map;*.css.map;*.ts.map;* har;* jslintrc;* jsonld)
R @1l ISON Lines (*jsonl;*.ndjson)

JSON with Comments (*jsonc;*.eslintrc;*.eslintrcjson;* jsfmtrc;* jshintrc;*.swerc* hintrc;* babelrc;* toolset,jsonc;*.code-workspace)
Julia (%j1)

Julia Markdown (*jmd)

LaTeX (*.tex;* Ix*.ctx)

' Less (*.less)

) save As Log (*log;**l0g.?)

Lua (*.lua)

~ Makefile (*.mak;*.mk)

Markdown (*.md;*. mkd;*. mkdn;* mdwn;*. mdown;*. markdown;*. markdn;* mdtxt;*. mdtext;* litcoffee)
MS SQL (*.sql;*.dsql)

Rendezés ¥ Uj nObjective-C (*.m)

Objective-C++ (*mm)

o _2026-igehirde|pgr| (*.pl*.pm;*.pod;*.t:* PLi*.psgi)

pinksd2 PHP (*.php;*.php4;*.php5;*.phtml;*.ctp)

PowerShell (*.ps1;*.psm1;*.psd1;*pssc;*.psrc)

Prompt (*prompt.md)

Properties (*.conf;* properties;*.cfg;*.directory;*.gitattributes;*.gitconfig;*.gitmodules;*.editorconfig;*.repo;*.npmrc)

print("Nem

o

fotok

® iCloud Drive

Ez a gép

DI
Raku (*.raku;*.rakumod;*.rakutest;* rakudoc;*.nqp;*.p6;*.pl6;*.pm6)
== Helyi lemez (Razor (*.cshtml;*.razor)
= pCloud Drive reStructuredText (*.rst)
Ruby (*.rb;*.rbx;*rjs;*.gemspec;*.rake;*.ru;*.erb;*.podspec;*.rbi)
. |Rust (~rs)
FajInev: |SCss (+.scss)

-> Python -> Mentés

Fajl tipusa:|| Plain Text (*.txt)

A~ Mappak elrejtése Mentés [ Mégse

3 Save As
€« v N « _2026-iskola > _digi-erettsegi-kozep > 05_python > 25.05
Rendezés v Uj mappa
o _2026-igehirdetes Né Modositas datur

o punkosd2

& iCloud Drive

W Ezagép
= Helyi lemez (C:)
p= pCloud Drive (P:

== pCloud Drive (P)

Fajinév: | kihivas.py

Fajl tipusa: Python (*.py;*.rpy;*.pyw;*.cpy:*.gyp;*.gypi;*.pyi;*.ipy;*.pyt)

A Mappék elrejtése

[
©

Mégse
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PyCharm [ -] o 2 BLZS

PyCharm Python 3.13 VS Code
. Community...

Suliban:
File -> New Project -> Create -> New Windows -> File -> New -> Python File

File Edit View Navigate Code Refactor Run

New Project...

Project from Version Control... BBl Yoy Navigate Code Refactor Run

New...

New Scratch File New Project...

[M Open... Project from Version Control...

New... Alt+Insert

New Ccratch File

lew window, or replace the project in
to the already opened projects.

Create ect?
 Python File
= Flle
= New Scratch File
New Window Attach Cancel .
(0 Directory

(51 Python Package

HTML File
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PyCharm 8LZS

& |

PyCharm Python 3.13 VS Code
. Community...

IEiIe Edit View Navigate Code Refactor Rur

New Project...
Project from Version Control...
—+, New File or Directory... Alt+Insert

Q
New Scratch File

(0 Open...

Save As...

@ Python File
= File
Recent Projects =° New Scratch File

Close Project (D Directory

Rename Project...

(& Python Package

e kitalalo.py
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